Setting Mikrotik dengan Speedy


Langkah pertama yg perlu dilakukan adalah konfigurasi modem, di sini saya tidak akan menjelaskan cara konfigurasi modem, di karenakan biasa nya sudah di konfigurasi oleh orang Speedy nya langsung, jadi pastikan bahwa modem sudah di konfigurasi dengan benar sampai terkoneksi internet dan bisa Online, apa bila modem belum di konfigurasi, anda bisa konfigurasi nya sendiri dengan melihat buku petunjuk yg di sertai dalam pembelian modem, coba za liat di dalam kardus modem nya pasti ada deh buku petunjuk nya, klo ga ada jg buku petunjuk nya, ya anda tanya za ya sma mbah goggle…..{hehehehehehehe……}

Langkah-langkah berikut adalah dasar-dasar setup mikrotik yang dikonfigurasikan untuk jaringan sederhana sebagai PC Router/Gateway, Web Proxy, DNS Server, DHCP, Firewall serta Bandwidth Management. Konfigurasi ini dapat dimanfaatkan untuk membangun jaringan pada Internet Cafe atau untuk Testing pada Laboratorium Pribadi. 

Persiapan :
- Untuk PC Router Siapkan PC, minimal Pentium I, RAM 64, HD 500M atau pake flash memory 64
- Sebagai Web proxy, Siapkan PC, minimal Pentium III 450Mhz, RAM 256 Mb, HD 20 Gb. Melihat berapa minimum RAM dan HD yang dibutuhkan untuk Cache Silahkan lihat http://adminpreman.web.id/download/Rumus Web Proxy Mikrotik.xls
- Siapkan minimal 2 ethernet card, 1 ke arah luar/Internet dan 1 lagi ke Network local
-  Burn Source CD Mikrotik OS masukan ke CDROM.
- Versi mikrotik yang digunakan adalah Mikrotik RouterOS versi 4.3

Installasi Mikrotik Router
 
Untuk proses instalasi Mikrotik lihat postingan sebelum nya
Umumnya Paket Mikrotik untuk Warnet, Kantor atau SOHO adalah :
  • SYSTEM : Paket ini merupakan paket dasar, berisi Kernel dariMikrotik 
  • DHCP : Paket yang berisi fasilitas sebagai DHCP Server, DHCP client, pastikan memilih paket ini jika Anda menginginkanagar Client diberikan IP address otomatis dari DHCP Server
  • SECURITY : Paket ini berisikan fasilitas yang mengutamakan Keamananjaringan, seperti Remote Mesin dengan SSH, Remote via MACAddress  
  • WEB-PROXY : Jika Anda memilih paket ini, maka Mikrotik Box anda telahdapat menjalan service sebagai Web proxy yang akan menyimpan cache agar traffik ke Internet dapat di reduksi serta browsing untuk Web dapat dipercepat. 
  • ADVANCED TOOLS : Paket yang berisi Tool didalam melakukan Admnistrasi jaringan, seperti Bandwidth meter, Scanning, Nslookup, dan lain sebagainya.
Setelah proses instalasi selesai, maka akan muncul menu login dalam modus terminal, kondisi sistem saat ini dalam keadaan default.

Mikrotik login = admin
Password = (kosong, enter saja)
CATATAN :

Konfigurasi Standar untuk mikrotik ada 2 modus, yaitu modus teks dan modus GUI. Modus Gui ada 2 juga, yaitu Via Browser serta Via Winbox.

Perintah mikrotik sebenarnya hampir sama dengan perintah yang ada dilinux,sebab pada dasarnya mikrotik ini merupakan kernel Linux, hasil pengolahan kembali Linux dari Distribusi Debian. Pemakaian perintah shellnya sama, seperti penghematan perintah, cukup menggunakan tombol TAB di keyboard maka perintah yang panjang, tidak perlu lagi diketikkan, hanya ketikkan awal nama perintahnya, nanti secara otomatis Shell akan menampilkan sendiri perintah yang berkenaan. Misalnya perintah IP ADDRESS di mikrotik. Cukup hanya mengetikkan IP ADD spasi tekan tombol TAB, maka otomatis shell akan mengenali dan menterjemahkan sebagai perintah IP ADDRESS. Setelah login, cek kondisi interface atau ethernet card.

Melihat kondisi interface pada Mikrotik Router
[admin@Mikrotik] > interface print
Flags: X - disabled, D - dynamic, R - running
# NAME TYPE RX-RATE TX-RATE MTU
0 R ether1 ether 0 0 1500
1 R ether2 ether 0 0 1500
[admin@Mikrotik]>

Jika interfacenya ada tanda X (disabled) setelah nomor (0,1), maka periksa lagi etherned cardnya, seharusnya R (running).

Mengganti nama interface
[admin@Mikrotik] > interface(enter)

Untuk mengganti nama Interface ether1 menjadi Public (atau terserah namanya), maka
[admin@Mikrotik] interface> set 0 name=Public
 

Begitu juga untuk ether2, misalkan namanya diganti menjadi Local, maka
[admin@Mikrotik] interface> set 1 name=Local

atau langsung saja dari posisi root direktori, memakai tanda "/", tanpa tanda kutip
[admin@Mikrotik] > /interface set 0 name=Public

Cek lagi apakah nama interface sudah diganti.
[admin@Mikrotik] > /interface print

Flags: X - disabled, D - dynamic, R - running
# NAME TYPE RX-RATE TX-RATE MTU
0 R Local ether 0 0 1500
1 R Public ether 0 0 1500

Mengganti password default
Untuk keamanan ganti password default
[admin@Mikrotik] > password
old password: *****
new password: *****
retype new password: *****
[admin@ Mikrotik]]>

Mengganti nama hostname

Mengganti nama Mikrotik Router untuk memudahkan konfigurasi, pada langkah ini nama server akan diganti menjadi “RedDevil"

[admin@Mikrotik] > system identity set name= RedDevil
[admin@ RedDevil]>


Setting IP Address, Gateway, Masqureade dan Name Server

IP Address


Bentuk Perintah konfigurasi
ip address add address ={ip address/netmask} interface={nama interface}

Memberikan IP address pada interface Mikrotik. Misalkan Public akan kita gunakan untuk koneksi ke Internet dengan IP 192.168.1.2 dan Local akan kita gunakan untuk network LAN kita dengan IP 192.168.0.1

[admin@ RedDevil] > ip address add address=192.168.1.2 netmask=255.255.255.0 interface=Public

[admin@ RedDevil] > ip address add address=192.168.0.1 netmask=255.255.255.0 interface=Local

Melihat konfigurasi IP address yang sudah kita berikan

[admin@ RedDevil] >ip address print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 ;;; IP Address ke Internet
192.168.1.2/24 192.168.0.0 192.168.1.255 Public
1 ;;; IP Address ke LAN
192.168.0.1/24 192.168.0.0 192.168.0.255 Local
 [admin@ RedDevil]>

Gateway

Bentuk Perintah Konfigurasi
ip route add gateway={ip gateway}

Memberikan default Gateway, diasumsikan gateway untuk koneksi internet adalah 192.168.1.1

[admin@ RedDevil] > /ip route add gateway=192.168.1.1

Melihat Tabel routing pada Mikrotik Routers

[admin@ RedDevil] > ip route print

Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf
# DST-ADDRESS PREFSRC G GATEWAY DISTANCE INTERFACE
0 ADC 192.168.0.0/24 192.168.0.30 Local
1 ADC 192.168.0.0/27 192.168.1.2 Public
2 A S 0.0.0.0/0 r 192.168.1.1 Public
[admin@ RedDevil]>

Tes Ping ke Gateway untuk memastikan konfigurasi sudah benar

[admin@ RedDevil] > ping 192.168.1.1
192.168.1.1 64 byte ping: ttl=64 time<1 ms
192.168.1.1 64 byte ping: ttl=64 time<1 ms
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 0/0.0/0 ms
[admin@ RedDevil]>

NAT (Network Address Translation)

Bentuk Perintah Konfigurasi

ip firewall nat add chain=srcnat action=masquerade out-inteface={ethernet yang langsung terhubung ke Internet atau Public}

Setup Masquerading, Jika Mikrotik akan kita pergunakan sebagai gateway server maka agar client computer pada network dapat terkoneksi ke internet perlu kita masquerading.

[admin@ RedDevil] > ip firewall nat add chain=scrnat out-interface=Public action=masquerade
[admin@ RedDevil]>

Melihat konfigurasi Masquerading

[admin@ RedDevil] ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic
0 chain=srcnat out-interface=Public action=masquerade
[admin@ RedDevil]>

Name server

Bentuk Perintah Konfigurasi
ip dns set primary-dns={dns utama} secondary-dns={dns ke dua}


Setup DNS pada Mikrotik Routers, misalkan DNS dengan Ip Addressnya Primary = 202.134.0.155, Secondary = 202.134.2.5

[admin@ RedDevil] > ip dns set primary-dns=202.134.0.155 allow-remoterequests=yes
[admin@ RedDevil] > ip dns set secondary-dns=202.134.2.5 allow-remoterequests=yes

Melihat konfigurasi DNS

[admin@ RedDevil] > ip dns print
primary-dns: 202.134.0.155
secondary-dns: 202.134.2.5
allow-remote-requests: no
cache-size: 2048KiB
cache-max-ttl: 1w
cache-used: 16KiB
[admin@ RedDevil]>

Tes untuk akses domain, misalnya dengan ping nama domain

[admin@ RedDevil] > ping yahoo.com
216.109.112.135 64 byte ping: ttl=48 time=250 ms
10 packets transmitted, 10 packets received, 0% packet loss
round-trip min/avg/max = 571/571.0/571 ms
[admin@ RedDevil]>

Jika sudah berhasil reply berarti seting DNS sudah benar.

Setelah langkah ini bisa dilakukan pemeriksaan untuk koneksi dari jaringan local. Dan jika berhasil berarti kita sudah berhasil melakukan instalasi Mikrotik Router sebagai Gateway server. Setelah terkoneksi dengan jaringan Mikrotik dapat dimanage menggunakan WinBox yang bisa di download dari Mikrotik.com atau dari server mikrotik kita. Misal Ip address server mikrotik kita 192.168.0.10, via browser buka http://192.168.0.10. Di Browser akan ditampilkan dalam bentuk web dengan beberapa menu, cari tulisan Download dan download WinBox dari situ. Simpan di local harddisk. Jalankan Winbox, masukkan Ip address, username dan password.

DHCP Server

DHCP merupakan singkatan dari Dynamic Host Configuration Protocol, yaitu suatu program yang memungkinkan pengaturan IP Address di dalam sebuah jaringan dilakukan terpusat di server,  sehingga PC Client tidak perlu melakukan konfigurasi IP Addres. DHCP memudahkan administrator untuk melakukan pengalamatan ip address untuk client.

Bentuk perintah konfigurasi
ip dhcp-server setup
dhcp server interface = { interface yang digunakan }
dhcp server space = { network yang akan di dhcp }
gateway for dhcp network = { ip gateway }
address to give out = { range ip address }
dns servers = { name server }
lease time = { waktu sewa yang diberikan }

Jika kita menginginkan client mendapatkan IP address secara otomatis maka perlu kita setup dhcp server pada Mikrotik. Berikut langkah-langkahnya :

a. Tambahkan IP address pool

/ip pool add name=dhcp-pool ranges=192.168.0.1-192.168.0.30

b. Tambahkan DHCP Network dan gatewaynya yang akan didistribusikan ke client.
Pada contoh ini networknya adalah 192.168.0.0/27 dan gatewaynya 122.168.0.1

/ip dhcp-server network add address=192.168.0.0/27 gateway=192.168.0.1 dns-server=192.168.0.1
comment=""

c. Tambahkan DHCP Server ( pada contoh ini dhcp diterapkan pada interface Local )

/ip dhcp-server add interface=local address-pool=dhcp-pool

d. Lihat status DHCP server

[admin@ RedDevil] > ip dhcp-server print

Flags: X - disabled, I - invalid

# NAME INTERFACE RELAY ADDRESS-POOL LEASE-TIME ADD-ARP

0dhcp1 Local

Tanda X menyatakan bahwa DHCP server belum enable maka perlu dienablekan terlebih dahulu pada langkah e.

e. Jangan Lupa dibuat enable dulu dhcp servernya

/ip dhcp-server enable 0

kemudian cek kembali dhcp-server seperti langkah 4, jika tanda X sudah tidak ada berarti sudah aktif

f. Tes Dari client

Misalnya :
C:>ping www.yahoo.com

Transparent Proxy Server

Proxy server merupakan program yang dapat mempercepat akses ke suatu web yang sudah diakses oleh komputer lain, karena sudah di simpan didalam caching server.Transparent proxy menguntungkan dalam management client,karena system administrator tidak perlu lagi melakukan setup proxy di setiap browser komputer client karena redirection dilakukan otomatis di sisi server.

Bentuk perintah konfigurasi :
a. Setting web proxy :

- ip proxy set enable=yes
port={ port yang mau digunakan }
maximal-client-connections=1000
maximal-server-connections=1000

- ip proxy direct add src-address={ network yang akan di NAT} action=allow

- ip web-proxy set parent-proxy={proxy parent/optional}
hostname={ nama host untuk proxy/optional}
port={port yang mau digunakan}
src-address={ address yang akan digunakan untuk koneksi ke parent proxy/default 0.0.0.0}
transparent-proxy=yes
max-object-size={ ukuran maximal file yang akan disimpan sebagai cache/default 4096 in Kilobytes}
max-cache-size= { ukuran maximal hardisk yang akan dipakai sebagai penyimpan file cache/unlimited | none | 12 in megabytes}
cache-administrator={ email administrator yang akan digunakan apabila proxy error, status akan dikirim ke email tersebut}
enable==yes
Contoh konfigurasi
-------------------

a. Web proxy setting

/ ip web-proxy
set enabled=yes src-address=0.0.0.0 port=8080
hostname="proxy.routerku.co.id" transparent-proxy=yes
parent-proxy=0.0.0.0:0 cache-administrator="support@routerku.co.id"
max-object-size=131072KiB cache-drive=system max-cache-size=unlimited
max-ram-cache-size=unlimited

Nat Redirect, perlu ditambahkan yaitu rule REDIRECTING untuk membelokkan  traffic HTTP menuju ke WEB-PROXY.

b. Setting firewall untuk Transparant Proxy

Bentuk perintah konfigurasi :

ip firewall nat add chain=dstnat
protocol=tcp
dst-port=80
action=redirect
to-ports={ port proxy }

Perintahnya:

--------------------------------------------------------------------------------
/ ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080
comment="" disabled=no
add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=8080
comment="" disabled=no
add chain=dstnat protocol=tcp dst-port=8000 action=redirect to-ports=8080
--------------------------------------------------------------------------------

perintah diatas dimaksudkan, agar semua trafik yang menuju Port 80,3128,8000  dibelokkan menuju port 8080 yaitu portnya Web-Proxy.

CATATAN:
Perintah

/ip web-proxy print { untuk melihat hasil konfigurasi web-proxy}
/ip web-proxy monitor { untuk monitoring kerja web-proxy}


Selamat mencoba...!!!

Subscribe to receive free email updates:

0 Response to "Setting Mikrotik dengan Speedy"

Poskan Komentar